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Kiwi CatTools 3.12.4 System Requirements
Updated: October 16, 2024

SolarWinds strongly recommends that you install Kiwi CatTools on a server that is neither 
public, nor internet-facing. To learn about best practices for configuring your Kiwi CatTools 
installation securely, see Best practices to secure SolarWinds products.

Before you install Kiwi CatTools, verify that your server meets the following minimum hardware and 
software requirements, and that the required ports are open.

Hardware and software requirements

Hardware and       Software      Requirements

Operating System      l Windows Server 2022
 l Windows Server 2019
 l Windows Server 2016
 l Windows Server 2012 R2
 l Windows 10
 l Windows 8.1

Hard drive space      200 MB      

CPU      1.2 GHz     

RAM      256 MB   

.NET Framework      Microsoft .NET Framework 4.8                    

Kiwi CatTools 3.12.4 System Requirements
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Port Requirements
 Kiwi CatTools 3.12.4 uses the following ports. 

Port Protocol Service Direction Description

22 TCP / UDP SSH Server Bidirectional SSH port for CatTools to transfer configs

23 Telnet Telnet Server Outbound Telnet port for CatTools to transfer configs

25 TCP SMTP 
Service

Outbound SMTP email port that CatTools uses for 
alerting

514 UDP/TCP Syslog 
Service

Outbound Sends log messages to a syslog server

161 UDP Kiwi Trap 
Service

Outbound Sending SNMP traps to a trap receiver

69 UDP TFTP Server Bidirectional TFTP port for CatTools to transfer config-files

4400 TCP Kiwi 
CatTools 
Service

Bidirectional Internal communication between the 
CatTools service and CatTools Manager.
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Install Kiwi CatTools
Use the following information to prepare the environment, install Kiwi CatTools, and enter a license 
key. 

Prepare the server

Review release 
notes

Review the Kiwi CatTools release notes.

Review system 
requirements

Verify that the server meets the hardware and software requirements.

Run all 
Windows 
updates

Check for and run all Microsoft Windows Updates on the server. If a 
Windows update runs, your system might reboot.

Open ports Verify that the server's firewall allows traffic to pass through the required 
ports for Kiwi CatTools.

Check for 
antivirus 
software

Determine if any antivirus software is installed on the server where you 
plan to install Kiwi CatTools. Exclude the SolarWinds directory. For 
example, on Windows Server 2016, exclude the directory:

C:\ProgramData\SolarWinds\

For a full list of antivirus exclusions, see Files and directories to exclude 
from antivirus scanning.

Do not exclude executable files. SolarWinds assumes that C:\ is the 
default volume.

Installation
Follow these instructions to install Kiwi CatTools.

Install Kiwi CatTools
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Download 
the 
installation 
file

 1. Log in to the SolarWinds Customer Portal. 

If you do not have a SolarWinds account, see Access the Customer 
Portal to create an account.

 2. Locate Kiwi CatTools under Latest Downloads for Your Products.

 3. Click Choose Download. 

Evaluators: Download your free 14-day evaluation from 
www.solarwinds.com/kiwi-cattools.

Run the 
installation 
file

 1. Log in to your server as an administrator.

 2. Extract the contents of the downloaded installation ZIP file to the 
server.

 3. Run Kiwi_CatTools_<version>.setup.exe.

If .NET Framework 3.5 is not installed, you are prompted to install it. 
Click Download and install this feature. Then restart Kiwi_CatTools_
<version>.setup.exe.
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Complete 
the Kiwi 
CatTools 
Setup 
Wizard

 1. On the Welcome dialog box, click Next.

 2. If you agree with the license agreement, click Next.

 3. Specify whether you want to install Kiwi CatTools as a service or an 
application.                         

When installing Kiwi CatTools you must choose to install Kiwi 
CatTools as an application or as a service:

 l Installing CatTools as an application is recommended if 
you need to run one-off or attended activities or for 
infrequent or part-time users who are running CatTools on 
their own personal computers.

 l Installing CatTools as a service is recommended for 
Enterprise customers, as well as anyone running 
unattended activities, who need to make use of around-
the-clock scheduling, or who are dedicating a machine 
specifically for CatTools to run on.

For more information on the differences between application 
mode and service mode, see Installing CatTools as an 
application or a service.

 4. If you are installing Kiwi CatTools as a Service:       

 a. Select Install CatTools as a Service, and click Next.

 b. Choose to install the service using either the local system 
account or an admin account.

 c. If installing using an administrator account, enter the account's 
user name and password.

 d. Click Next.

 5. If you are installing Kiwi CatTools as an Application:

 a. Select Install CatTools as an Application.

 b. Click Next.

 6. Select the shortcuts to create, and click Next.

 7. Specify the installation location, and click Install.

The installer displays status messages as Kiwi CatTools is installed.

Close the 
Wizard. 

Click Finish to close the Kiwi CatTools Setup Wizard and open the 
Kiwi CatTools Manager.

Installation
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Next steps
 l After installation, see the Kiwi CatTools Getting Started Guide for configuration and 

troubleshooting tips.
 l Enter a license key to activate the licensed edition of Kiwi CatTools.
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Activate a Kiwi CatTools license key
After installing Kiwi CatTools, you can access all features for 14 days without a license. After the 14-
day trial period, you must enter a license key to continue to access licensed features. 

Activate licenses online
If Kiwi CatTools is connected to the internet, you can activate the license online. If your server does 
not have internet access, see Activate licenses offline.

 1. Complete the following steps to retrieve your license activation key from the Customer Portal.

If you are evaluating KCT or have received a license activation key from a SolarWinds 
representative, continue with step 2.

 a. Log in to the SolarWinds Customer Portal. If you do not have a SolarWinds account, see 
Access the Customer Portal to create an account.

 b. Choose Licenses > Manage Licenses.

 c. Locate the license, and expand it.

 d. Copy the activation key.

 2. In the Kiwi CatTools Manager, select Help > Enter registration details. 

 3. Select "I have internet access and an activation key...".

 4. Enter the license / activation key, and click Next.

If you are using a proxy server to activate your license, check "I access the internet through a 
proxy server" and enter the proxy address, port, username, and password, as necessary.

 5. Enter the registration information, and click Next.

 6. Restart the Kiwi CatTools Manager.

Activate licenses offline
Manual license activation is necessary if your server does not have internet access or is having 
activation issues due to a proxy server.

Offline activation requires a transfer of files between the KCT server and a computer connected 
to the Internet. You can use email, shared storage, or a USB flash drive to transfer the files.

Activate a Kiwi CatTools license key
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 1. In the Kiwi CatTools Manager, click Help > Enter registration details. 

 2. Select This server does not have internet access. Guide me through offline, 
manual activation, and click Next.

 3. Click Copy Unique Machine ID.

 4. Paste the Unique Machine ID into a text editor document. You will use this ID in the next step.

 5. Complete the following steps to obtain a license activation file from the Customer Portal.

If you are evaluating KCT and have received a license activation file from a SolarWinds 
representative, continue with step 7.

On a computer with internet access:

 a. Log in to the SolarWinds Customer Portal

 b. Browse to Licenses > Manage Licenses.

 c. Locate the Kiwi product you are activating.

 d. Click Activate license manually.

 e. Enter the required contact information. The activation key is entered for you and cannot be 
changed.

 f. Enter the Unique Machine ID copied from Step 3.

 g. Click Generate License File to download your license key (.lic) file.

 h. Save this file to a location on your product's server.

 6. Open the activation window and browse to the saved License Key File location.

 7. Click Open.

 8. Click Next to apply the key.

 9. Once the activation has been confirmed, click Finish.

 10. Click Restart Syslog Server.
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Kiwi CatTools 3.12.4 Upgrade Guide
Supports: Kiwi CatTools 3.12.4 and earlier

Preflight checklist
Complete the checklist below to prepare for upgrading Kiwi CatTools.

Review release 
notes

Review the Kiwi CatTools release notes.

Review system 
requirements

Verify that the server meets the hardware and software requirements.

Run all 
Windows 
updates

Before the upgrade, check for and run all Microsoft Windows Updates on 
the server. As you upgrade, if a Windows update runs, your system might 
reboot.

Check for and 
disable anti-
virus software

Determine if any anti-virus software is installed on the server where you 
plan to install Kiwi CatTools. To ensure the installation goes smoothly, 
exclude the SolarWinds directory. For example, on the Windows Server 
2012 R2, exclude the following directories:

 l C:\ProgramData\SolarWinds

Upgrade Kiwi CatTools
When you upgrade to the latest version of Kiwi CatTools, your devices, scheduled actions, and other 
configuration settings are preserved. If you previously entered a license key, the key is automatically 
applied to the new version.

If you upgrade from KCT 3.12.2, the Kiwi CatTools database will automatically update and your 
data will be re-encrypted using AES (Advanced Encryption Standard). If the database updates, 
the changes cannot be reverted. 

While a typical upgrade takes approximately one minute to perform, this does not include the time 
required to backup your system or perform upgrade validation testing.

Kiwi CatTools 3.12.4 Upgrade Guide
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When updating Kiwi CatTools you must choose to install the Kiwi CatTools update as an 
application or as a service:

 l Installing CatTools as an application is recommended if you need to run one-off or 
attended activities or for infrequent or part-time users who are running CatTools on their 
own personal computers.

 l Installing CatTools as a service installation is recommended for Enterprise customers, as 
well as anyone running unattended activities, who need to make use of around-the-clock 
scheduling, or who are dedicating a machine specifically for CatTools to run on.

For more information on the differences between application mode and service mode, see 
Installing CatTools as an application or a service.

Backup your 
existing 
installation

Make a full backup of your existing installation, including the database. See 
Backup current database.

It is critical to create a backup of your KCT database from a previous 
version of KCT. If you downgrade from KCT 3.12.2 to a previous version, 
the data in the KCT database cannot be retrieved once the upgrade is 
complete.

Uninstall the 
current 
version

 1. Select File > Exit to close the console.     

 2. Uninstall Kiwi CatTools using Windows Control Panel > Uninstall a 
program.     

 3. If Kiwi CatTools Manager is installed, click Yes when you are prompted to 
uninstall it. 

Download the 
installation 
file

 1. Go to the SolarWinds Customer Portal and log in. 

If you do not have a SolarWinds account, see Access the Customer Portal 
to create an account.

 2. Locate Kiwi CatTools under Latest Downloads for Your Products.     

 3. Click Choose Download. 

Run the 
installation 
file

 1. Log in using an administrator level account.     

 2. Extract the contents of the downloaded installation .zip file to the server.     

 3. Run Kiwi_CatTools_<version>.setup.exe.     

If .NET Framework 4.8 is not installed, you are prompted to install it. Click 
Download and install this feature. Then restart Kiwi_CatTools_
<version>.setup.exe

Installation and Upgrade Guide: Kiwi CatTools page 13

Upgrade Kiwi CatTools

https://documentation.solarwinds.com/en/success_center/kct/Content/KCT_AG_Intro_AppVsService.htm#Application
https://documentation.solarwinds.com/en/success_center/kct/Content/KCT_AG_Intro_AppVsService.htm#Service
https://documentation.solarwinds.com/en/success_center/kct/Content/KCT_AG_Intro_AppVsService.htm
https://documentation.solarwinds.com/en/success_center/kct/content/kct_ag_backup_current_database.htm
https://customerportal.solarwinds.com/
https://support.solarwinds.com/Success_Center/Network_Performance_Monitor_(NPM)/NPM_Documentation/Network_Performance_Monitor_Getting_Started_Guide/070_Get_connected/010_Access_the_Customer_Portal


Complete the 
Kiwi CatTools 
Setup wizard

 1. On the Welcome dialog box, click Next. 

 2. If you agree to the license agreement, click Next.     

 3. Specify whether you want to install Kiwi CatTools as a service or an 
application. 

 l Installation as a service allows the program to run without the need 
for a user to log in to Windows. This option also installs CatTools 
Manager which is used to control the service. 

 l Installation as an application requires a user to log in to Windows 
before running the program. 

 4. If you are installing Kiwi CatTools as a Service:         

 a. Select Install CatTools as a Service, and click Next.         

 b. Choose to install the service using either the local system account 
or an admin account. 

 c. If installing using an administrator account, enter the account's 
username and password. 

 d. Click Next.     

 5. If you are installing Kiwi CatTools as an application: 

 a. Select Install CatTools as an Application. 

 b. Click Next.     

 6. Select the shortcuts to create, and click Next.     

 7. Specify the installation location, and click Install.  

The installer displays status messages as Kiwi CatTools is installed.

Close the 
Wizard

Click Finish to close the Kiwi CatTools Setup wizard and open Kiwi CatTools 
Manager. 

Start 
CatTools in 
application 
mode

Start the new update in application mode the first time, then change to service 
mode, if required.

Upgrade Kiwi CatTools
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Troubleshooting  installing or upgrading 
Kiwi CatTools
There are a number of resources available if you are experiencing issues after installing or upgrading 
Kiwi CatTools. See Troubleshooting or THWACK Kiwi CatTools for more troubleshooting resources.

If the issue persists, contact support or submit a ticket in the Customer Portal.
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